В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
thebesteconomist
thebesteconomist
27.02.2022 19:14 •  Информатика

Известно, что 1 число месяца-день недели среда. составить программу, которая после ввода любого числа в этом месяце выдаёт какой это день недели

Показать ответ
Ответ:
zhgulevatanya
zhgulevatanya
07.10.2020 23:31
Var d, n: integer;
begin
write('Номер дня недели первого числа месяца (1..7): ');
readln(d);
write('День месяца (1..31): ');
readln(n);
write('Это ');
case (n + d - 2) mod 7 of
0: write('понедельник');
1: write('вторник');
2: write('среда');
3: write('четверг');
4: write('пятница');
5: write('суббота');
6: write('воскресение')
end;
readln
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота