Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
пелы
12.04.2020 13:37 •
Информатика
Известны оценки за контрольную по информатике n учащихся.составте программу,которая вычисляет среднюю оценку(без использования массива).
Показать ответ
Ответ:
Никита256366
26.08.2020 18:22
// PascalABC.NET 3.3, сборка 1573 от 04.11.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Средняя оценка ',ReadSeqInteger(ReadInteger('n=')).Average:0:1)
end.
Пример
n= 7
5 4 4 3 4 2 3
Средняя оценка 3.6
0,0
(0 оценок)
Популярные вопросы: Информатика
Nika75556
26.04.2020 09:21
Необходимо, чтоб программа выводила на экран вот такую последовательность: 8 16 24 32 40 48 56 … N...
unicorn337228
27.11.2021 00:52
Сканируется цветное изображение 10 х 10 см^2 (2 в квадрате). разрешающая сканера - 600 х 1200 dpi, глубина цвета - 2 байта. какой информационный объём будет иметь полученный...
daniil9211
27.11.2021 00:52
Определите форму мышления: м.ю. лермонтов родился в 1841 году. 1 суждение 2 умозаключение 3 понятие...
lebedevamilp00sr9
27.11.2021 00:52
Какие виды выравнивания доступны в текстовом редакторе wordpad?...
vvbybrjnbr
15.03.2020 13:59
Задание 1. Расписать целое восьмеричное число 41538 в развёрнутой форме. Задание 2. Перевести число 41538 из восьмеричной системы счисления в десятичную. Задание 3. Перевести...
Xom9l4ok
20.09.2020 15:29
С++ Написать программу вычисления площади параллелограмма. Ниже приведен рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным...
tach11
20.07.2021 03:21
1. Какие из перечисленных групп устройств находятся в системном блоке? 1) Джойстик, винчестер, процессор; 2) Винчестер, оперативная память, флэш-память; 3) Винчестер, процессор,...
makismunguran
29.12.2020 02:37
Запишите возможные команды исполнителя Рисователь?...
perminovdima20
17.12.2022 23:23
Неформальний кодекс поведінки, за яким певним чином регулюється спілкування користувачів в Інтернеті між собою Спам Право Етикет Смайлик Питання №2 ? Для передавання емоцій...
zjablja
19.09.2021 15:09
Обчисліть довжину двійкового коду деякого тексту за умови, що символи тексту закодовані з використанням таблиці кодів символів Windows-1251.Текст складає 64 сторінки, кожна...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
Writeln('Средняя оценка ',ReadSeqInteger(ReadInteger('n=')).Average:0:1)
end.
Пример
n= 7
5 4 4 3 4 2 3
Средняя оценка 3.6