В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
hupri05
hupri05
06.12.2022 21:17 •  Информатика

JAVA Напишите программу калькулятор. В ней задается три переменных: a (тип int, хранит первое значение), b (тип int, хранит второе значение) и op (тип int хранит код операции:1 –
сложение, 2 – вычитание, 3 – умножение, 4 – деление). Программа должна совершить операцию с двумя переменными a и b, в зависимости от кода операции. Например, a=10; b= 20;
op=3 – в результате программа выведет 200. Поиграйтесь с различными значениями. Обязательно добавьте проверки на неправильные значения (нулевые, отрицательные), проверку
на деление на ноль.

Показать ответ
Ответ:
Sa4eR
Sa4eR
22.05.2022 08:39

Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.Изучите несплошной текст. Создайте связный сплошной текст (4-5 предложений), описывая и анализируя информацию несплошного текста.

Объяснение:

0,0(0 оценок)
Ответ:
Yana18102001
Yana18102001
27.01.2023 19:48
#include "stdafx.h"
#include <stdio.h>
#include <windows.h>

int main()  
  {
    SetConsoleCP(1251);      
    SetConsoleOutputCP(1251);  
 
int const n=3;
int mas[n][n];
int sum1, sum2;
bool magik;

for (int i=0; i<n; i++)
    for (int j=0; j<n; j++)
         {
           printf("mas[%d][%d] = ", i+1, j+1);
           scanf("%d",&mas[ i ][ j ]);
         }

printf("\nВведенная матрица:\n");
     for (int i=0; i<n; i++)
        {
             for (int j=0; j<n; j++)
                       {
                          printf("%d  ",mas[ i ][ j ]);
                       }
             printf("\n");
         }

sum1=0;
sum2=0;

for (int i = 0; i<n; i++)
     {
            sum1 += mas[ i ][ i ];
            sum2 += mas[ i ][ n-1-i ];
      }

printf("Сумма главной диагонали = %d\n", sum1);
printf("Сумма побочной диагонали = %d\n", sum2);

magik = true;
for (int i=0; i<n; i++)
    {
        if (sum1==sum2)
             {
                 sum2=0;
                 for (int j=0; j<n; j++)
                    {
                        sum2 += mas[ i ][ j ];
                     }
              } else  { magik=false; break; }
     }

if (magik==true)
     {
           for (int i=0; i<n; i++)    
               {
                   if (sum1==sum2)
                        {
                           sum2=0;
                           for (int j=0; j<n; j++)
                               {
                                   sum2 += mas[ j ][ i ];
                               }
                         }
                        else  { magik=false; break; }
                 }
       }

if (magik==true)
    printf("\nМатрица является магическим квадратом\n");  
else
    printf("\nМатрица не является магическим квадратом\n");

system("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота