В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Hah125
Hah125
20.01.2023 13:11 •  Информатика

Java. Необходимо составить программу решения линейного уравнения ax + b = 0 (а <> 0). Знаю, задача но после С# сложно адаптироваться.

Показать ответ
Ответ:
irochkakarpenkp0bint
irochkakarpenkp0bint
15.10.2020 13:13

package testStudentCode;

//import java.util.Arrays;

import java.util.Scanner;

public class TestStudentCode {

public static void main(String[] args) {

/* This reads the input provided by user

        * using keyboard

        */

       Scanner scan = new Scanner(System.in);

       System.out.print("a = ?");

       // This method reads the number provided using keyboard

       double a = scan.nextDouble();

       System.out.print("b = ?");

       double b = scan.nextDouble();

       // Closing Scanner after the use

       scan.close();

       System.out.println(a + "x + (" + b + ") = 0");  

       if (a == 0) {

        System.out.println("a = 0");

       } else {

           double x = - b / a;

        System.out.println("x = " + x);

       }

}

}

Объяснение:

как то так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота