В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
hatidzemustafaeva
hatidzemustafaeva
12.02.2020 13:44 •  Информатика

Как это ( в паскале.) в магазине трилайн периодически бывают скидки. составить программу, которая запрашивает цену покупаемого товара и его количество, информацию о скидке (в процентах, если скидки нет, то ввести 0%). на печать должна выводиться сумма к оплате.

Показать ответ
Ответ:
амоооооооо
амоооооооо
17.06.2020 09:28

Поверено на Паскале АВС

 

Program PSM;
uses crt;
var
  cena, summa:real;
  kwo,skid : integer;
begin
  writeln('*** alphaues is thinking... ***');
  writeln('***          OK             ***');
  writeln;  writeln;
  writeln('++');
  writeln('|             Приветствуем вас в магазине ТРИЛАЙН!              |');
  writeln('++');
  writeln('|       Введите необходимую информацию ниже:       |');
  writeln('++');
  write('       Цена товара:  '); readln(cena);
  write('       Количество единиц товара:  '); readln(kwo);
  write('       Размер скидки в % (0 - если скидки нет) '); readln(skid);
  writeln('++');
  writeln('|                                                               |');
  writeln('|                 Сумма к оплате: ',cena*kwo*(1-skid/100):10:2,'                    |');
  writeln('|                                                               |');
  writeln('++');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота