Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Діана25123456789000
20.11.2021 18:10 •
Информатика
Как на pascal abc написать программу, которая будет считать сумму цифр числа, введенного с клавиатуры? количество цифр в числе неизвестно! число целое. желательно с объяснениями (вне программы). заранее ! p.s. я 15 ! !
Показать ответ
Ответ:
NastyaMishacheva
30.08.2020 17:13
Program LOL2016;
var n,s,r:integer;
begin
readln(n);
s:=0;
while(n <> 0) do begin
r:=n mod 10;
s:=s+r;
n:=n div 10;
end;
writeln(s);
end.
если что то не понятно просто спроси и я обьясню :)
0,0
(0 оценок)
Популярные вопросы: Информатика
jddgvdysf
09.05.2023 11:38
В летнем лагере отдыхало 88 семиклассников (-а). 6 из них не любят компьютерные игры. 53семиклассника (-ов) предпочитают квесты, 62 — симуляторы. Сколько ребят...
Vikak005love
30.03.2020 15:20
3. найти сумму всех натуральных двузначных чисел, делящихся на 7...
angeljulia20033
15.07.2020 19:08
Написать программу которая выводит таблицу квадратов первых 10 целых положительных чисел...
rakhmanets
06.04.2022 07:30
Одно из значений слова редактор - лицо, исправляющее рукопись с согласия автора. попытайтесь на основе этой информации объяснить, почему компьютерные программы...
kekys326
23.04.2023 11:27
3. для исходной логической функции построить таблицу истинности: (а v в) & (а v с) & (в → с)...
Матвей2048602
28.10.2020 03:32
Около школы разбили клумбу в форме круга радиусом r м. на 1м² площади требуется х г семян цветов. сколько граммов семян надо купить? площадь круга вычисляется по...
Vlada1815
07.06.2023 08:29
1. найти значения логического выражения: (1 v 1) v (1 v 0) (подробно)...
Dyakgod
03.02.2020 17:45
Запишите в развёрнутом виде числа: 23460 в 8 , 23460 в 16, 23460 в 5, 23460 в 2. 129 в 2 , 129 в 8 , 129 в 16, 129 в 5. 63 в 2, 63 в 8, 63 в 16, 63 в...
alex3942
03.02.2020 17:45
Решите . максимальная скорость передачи данных в локальной сети 100 мбит/с. сколько страниц текста можно передать за 1 сек, если 1 страница текста содержит 50 строк...
khalitovroman
22.06.2020 22:29
Решите . максимальная скорость передачи данных в локальной сети 100 мбит/с. сколько страниц текста можно передать за 1 сек, если 1 страница текста содержит 50 строк...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var n,s,r:integer;
begin
readln(n);
s:=0;
while(n <> 0) do begin
r:=n mod 10;
s:=s+r;
n:=n div 10;
end;
writeln(s);
end.
если что то не понятно просто спроси и я обьясню :)