В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Как написать программу, которая в последовательности чисел (количество вводится с клавиатуры) определяет сумму чисел, кратных 9 и оканчивающихся на 3. pascalabc.net

Показать ответ
Ответ:
Kristing15
Kristing15
01.10.2020 20:18
Var
a: array of integer;
i,n, s: integer;
begin
write('Введите количество чисел: ');
readln(n);
SetLength(a, n);
s:=0;
for i:=0 to n-1 do 
begin 
write('Введите число', i+1, ': '); 
readln(a[i]); 
if (a[i] mod 9 = 0) and (a[i] mod 10 = 3) then s:=s+a[i]; 
end;
writeln;
writeln('Исходный массив:');
for i:=0 to n-1 do write(a[i]:5);
writeln;
writeln('Сумма чисел, кратных 9 и оканчивающихся на 3 = ', s:5);
a:=nil;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота