В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
222вовчик222
222вовчик222
02.06.2021 16:15 •  Информатика

Как написать программу в pascal в строчку, которая выводит разряды числа 12321? )

Показать ответ
Ответ:
lenocekkotik856
lenocekkotik856
10.10.2020 06:42

program Example2;

var

 a, i: Integer;

begin

 Write ('Введете целое число: ');

 ReadLn (a);

 WriteLn;

 Write ('Разряды числа: ');

 while a > 0 do begin

   Write (a mod 10, ' ');

   a := a div 10;

 end;

 ReadLn;

end.

Объяснение:

mod -  выделяем последнюю цифру

div - отбрасываем последнюю цифру

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота