В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Nastenok122
Nastenok122
12.06.2022 03:44 •  Информатика

Как составить программу вычисления и выдачи на печать суммы (или произведения) n элементов бесконечного числового ряда .следует пользоваться операторами цикла for: y=125(-25)5(-1)0,

Показать ответ
Ответ:
gilewich
gilewich
02.10.2020 11:52
1  var k,i,n,c:integer;
2     p,w:real;
3  begin
4  repeat
5  write('k>-3 k=');
6  readln(k);
7  until k>-3;
8  w:=0;
9  c:=1;
10  for i:=-3 to k do
11    begin
12     c:=-c;{-1^i}
13     p:=1;
14     for n:=i to 2*k do
15     if n<>2 then p:=p*(n*n*n-8);
16     if i<>5 then w:=w+(c/sqr(i-5))*p;
17    end;
18   write('W=',w:0:4)
19   end.

Это?
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота