Как в scratch нарисовать цепь из колец? и как составить программу (спрайта2) для рисования мыльных пузырей (минимум 7 штук) – окружности разного цвета, разного диаметра, в разных частях экрана ?
Программное обеспечение (ПО) - совокупность специальных программ, облегчающих процесс подготовки задач к выполнению на ЭВМ и организующих прохождение через машину, а также процедур, описаний, инструкций и правил вместе со связанной с этими компонентами документацией, используемых при эксплуатации вычислительной системы. Именно программы обрабатывают информацию и управляют работой компьютера, а не устройства. Назначение (роль) ПО: Обеспечение работо ПК; Облегчение взаимодействия пользовался с ПК; Сокращение цикла от постановки задач до получения результата; Повышение эффективности использования ресурсов ПК. ПО позволяет: Усовершенствовать организацию работы вычислительной системы с целью максимального использования ее возможностей; Повысить производительность и качество труда пользователя; Адаптировать программы пользователя к ресурсам конкретной вычислительной системы; Расширить ПО вычислительно системы.
int main(){
int *enter = new int;
cout << "Enter x: "; cin >> *enter; const int *x = new int(*enter); *enter = 0; cout << "Enter y: "; cin >> *enter; const int *y = new int(*enter);
int *mat = new int[*x][*y];
for (int i = 0; i < *x; i++){ for (int j = 0; j < *y; j++){ cout << "Enter [" << i << "][" << j << "]: "; cin >> mat[i][j]; }; };
int *max = new int(0);
for (int i = 0; i < *x; i++){ if (mat[*x] > *max){ *max = mat[*x]; }; };}
Именно программы обрабатывают информацию и управляют работой компьютера, а не устройства.
Назначение (роль) ПО:
Обеспечение работо ПК;
Облегчение взаимодействия пользовался с ПК;
Сокращение цикла от постановки задач до получения результата;
Повышение эффективности использования ресурсов ПК.
ПО позволяет:
Усовершенствовать организацию работы вычислительной системы с целью максимального использования ее возможностей;
Повысить производительность и качество труда пользователя;
Адаптировать программы пользователя к ресурсам конкретной вычислительной системы;
Расширить ПО вычислительно системы.