В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
victoria128
victoria128
07.10.2022 23:02 •  Информатика

Как вывести функцию сравнения двух чисел в паскале с mod и div не используя if? напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

Показать ответ
Ответ:
dhgdfnhflk
dhgdfnhflk
07.10.2020 05:01
var a,b,a1,b1:word;
 begin
writeln('Введите два натуральных числа');
readln(a,b);
a1:=a div b;
 a1:=((a1+2) div (a1+1)) mod 2;
 b1:=(a1+1) mod 2;
writeln('Число ', a*a1+b*b1,' не меньше ',a*b1+b*a1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота