Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
балагуш
27.12.2021 22:06 •
Информатика
Каждый ежедневно болеющий гриппом человек может заразить окружающих. составьте программу, определяющую, через сколько дней заболеют все ученики школы. число учащихся школы ввести с клавиатуры.
Показать ответ
Ответ:
Карычч
01.10.2020 17:52
При условии что каждый больной заражает от 1 до 5 человек каждый день, и что больные упорно ходят в школу
const
min_posible = 1;
max_posible = 5;
var all_students, ill, new_ill, days, i: integer;
Begin
Randomize;
Writeln('Кол-во учеников школы =>');
read(all_students);
ill := 1;
repeat
days := days + 1;
new_ill := 0;
for i := 1 to ill do
new_ill := new_ill + Random(min_posible, max_posible);
ill := ill + new_ill;
Writeln('День ',days:3,': Заразилось ',new_ill:5,' Больных ',ill:5);
until ill >= all_students;
Writeln(days);
End.
0,0
(0 оценок)
Популярные вопросы: Информатика
Seasons1
05.06.2020 22:08
Во Выберите правильную запись полной формы ветвления. Укажите правильный вариант ответа: 1)If условие then оператор1 else оператор2 2)If условие then оператор2 3)If условие else...
asyamilos
13.09.2021 02:21
Дано вещественное число а и целое число n ( o) используя один цикл найти сумму. 1+ а+ а ( в кд.) + а (в кубе) + . . + а ( в n)...
shahboz3
13.09.2021 02:21
Дана матрица состоящая из 5 строк и 10 столбцов заполненная случайными числами в диапазоне от 0 до 29.сформировать одномерный массив sum(название массива) который состоит из сумм...
ангел809
13.09.2021 02:21
Написать программу которая выводит таблицу значений функции y=|x+2| диапазон изменения аргумента от -4 до 4 плз составить программу в паскале...
Солі
13.09.2021 02:21
Решите .турист идет к озеру. у развилки дороги сидят 2 брата и каждый из них знает,какая дорога ведет к озеру.. на вопросы братья отвечают только да и нет. один из них всегда говорит...
Валерия3365
13.09.2021 02:21
Составить программу в паскале с движущимся шариком по окружности....
sveta465
07.03.2020 12:42
Чому мітохондрії і пластиди називаються двомембранними органелами?...
sexmachina098
04.09.2020 17:46
4. Біт — це: а) двійкова цифра; б) двійкове число; в) двійковий знак; г) двійковий код. 5. Збільшення довжини коду на один біт приводить до збільшення множини різних кодів, які...
спасибо88
11.03.2022 16:03
Выполнить действия 1. 100111+10101 в двоичной системе счисления...
Tringt
23.12.2020 12:07
Некто продал лошадь за 196р, но покупатель преобретя лошадь раздумал её покупать за такую цену. тогда продавец предложил купить только все подковные гвозди, а лошадь в придачу...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
const
min_posible = 1;
max_posible = 5;
var all_students, ill, new_ill, days, i: integer;
Begin
Randomize;
Writeln('Кол-во учеников школы =>');
read(all_students);
ill := 1;
repeat
days := days + 1;
new_ill := 0;
for i := 1 to ill do
new_ill := new_ill + Random(min_posible, max_posible);
ill := ill + new_ill;
Writeln('День ',days:3,': Заразилось ',new_ill:5,' Больных ',ill:5);
until ill >= all_students;
Writeln(days);
End.