В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kir1kir1
kir1kir1
16.10.2021 04:48 •  Информатика

класс.
Python.
Дан массив, содержащий 8 положительных целых чисел, не превышающих 1000
Необходимо найти в этом массиве количество двузначных элементов, которые кратны числу 5,
и заменить каждый из таких элементов на это количество. Напишите программу для решения
этой задачи. В качестве результата программа должна вывести изменённый массив, по одному
элементу в строке.
Язык программирования Python.

Показать ответ
Ответ:
mkogavuk
mkogavuk
04.08.2020 01:26

n = int(input())

#Сколько чисел

value = []

z = 0

for i in range(n):

   t = int(input())

   value.append(t)

   if t // 100 == 0 and t % 5 == 0:

       z += 1

for i in value:

   if i // 100 == 0 and i % 5 == 0:

       g = value.index(i)

       value.remove(i)

       value.insert(g, z)

for i in value:

   print(i)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота