В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
ЛераКотМи
ЛераКотМи
19.04.2021 21:13 •  Информатика

Код на питона и на с Разложение на чётнопростые
В этой задаче рассматриваются только чётные целые числа.

Чётное натуральное число n будем называть чётнопростым числом, если его нельзя представить в виде произведения двух чётных чисел. Например, числа 2 и 6 — чётнопростые.

Очевидно, что каждое число либо является чётнопростым, либо разлагается в произведение чётнопростых. Но такое разложение на чётнопростые не всегда единственно.

Входные данные

Дано чётное натуральное n≤109.

Выходные данные

Если число n чётнопростое, выведите слово prime. Если это число единственным образом разлагается в произведение двух и более чётнопростых, то выведите слово single, а в следующей строке выведите разложение этого числа на чётнопростые множители. Если число допускает несколько различных разложений на чётнопростые, то выведите слово many, а в следующих двух строках выведите два каких-нибудь различных разложения числа на чётнопростые множители.

Примеры
Ввод 1
6
Вывод
prime
Ввод 2
4
Вывод
single
2 2

очень на вас надеюсь

Показать ответ
Ответ:
dasha010598
dasha010598
10.06.2022 08:48
Microsoft Word (часто — MS Word или просто Word) — текстовый процессор, предназначенный для создания, просмотра и редактирования текстовых документов, с локальным применением простейших форм таблично-матричных алгоритмов. Выпускается корпорацией Microsoft в составе пакета Microsoft Office. Первая версия была написана Ричардом Броди (Richard Brodie) для IBM PC, использующих DOS, в 1983 году. Позднее выпускались версии для Apple Macintosh (1984), SCO UNIX и Microsoft Windows (1989). Текущей версией является Microsoft Office Word 2016 для Windows и macOS.
0,0(0 оценок)
Ответ:
Заразный1
Заразный1
26.02.2021 19:05
Var
  A: array [1 .. 5] of real;
  i, j: byte;
  sum, tmp: real;

begin
  sum := 0;

  { Заполнение массива }
  for i := 1 to 5 do
  begin
    write('A[', i, '] = ');
    readln(A[i]);
    sum := sum + A[i]; // подсчет суммы
  end;
  writeln(#13 + 'Сумма элементов = ', sum);

  { Сортировка по убыванию }
  for i := 1 to 4 do
    for j := i + 1 to 5 do
      if A[i] < A[j] then
      begin
        tmp := A[i];
        A[i] := A[j];
        A[j] := tmp;
      end;

  { Вывод }
  writeln('Отсортированный массив: ');
  for i := 1 to 5 do
    write(' ', A[i]);

end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота