Компоненты переменной v представляют собой ежедневный доход предприятия .напишите программу которая подсчитывает средний ежедневный доход.(относиться к турбо паскаль) описание type zi (это типо дни как на молдавском пишется )=(p,v,s,c,p,s,v)-дни недели venit(с нашего языка пришел или пришли)=array [zi] of real; var v: venit;
const
n = 7;
s = 'PVSCPSV';
var
v: array[1..n] of double;
i: integer;
m: double;
begin
Writeln('Вводите суммы ежедневного дохода по дням');
m := 0;
for i := 1 to n do
begin
Write(s[i], ': ');
Readln(v[i]);
m := m + v[i]
end;
Writeln('Средний доход за неделю составляет ', m / n:0:3)
end.
Тестовое решение:
Вводите суммы ежедневного дохода по дням
P: 142539
V: 363135
S: 217432
C: 57395
P: 294722
S: 115390
V: 184933
Средний доход за неделю составляет 196506.571