В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
baburinyaroslav
baburinyaroslav
20.02.2020 18:37 •  Информатика

Контрольная работа по циклам в языке Паскаль
Вариант 2
1. Определите значение переменной с после вы-
полнения следующих операторов. Запишите
значения переменных и условия на каждом
шаге в виде таблицы.
а
s:=0; i:=1;
while i<=5 do begin
S = sti-2
i:=i+2;
end;
Выберите
б)
for i:=1 to 3 do s:=s*i;
В
s: = 3; :=-2,
repeat
s:=s*,
j:=j+1;
until j>0;​

Показать ответ
Ответ:
Sveta7102006
Sveta7102006
02.08.2021 19:33

Современным компьютерам предшествовали ЭВМ нескольких поколений. В развитии ЭВМ выделяют пять поколений. В основу классификации заложена элементная база, на которой строятся ЭВМ.   1. В 1943 году была создана вычислительных машин ЭВМ первого поколения на базе электронных ламп.  2. Второе поколение (50 – 60 г. г. ) компьютеров построено на базе полупроводниковых элементов (транзисторах) .  3. Основная элементная база компьютеров третьего поколения (60 – 70 г. г. ) - интегральные схемы малой и средней интеграции.  4. В компьютерах четвертого поколения (70 – по н/в) применены больших интегральных схемах БИС (микропроцессоры) . Применение микропроцессоров в ЭВМ позволило создать персональный компьютер (ПК) , отличительной особенностью которого является небольшие размеры и низкая стоимость.  5. В настоящее время ведутся работы по созданию ЭВМ пятого поколения, которые разрабатываются на сверхбольших интегральных схемах. Объяснение:

0,0(0 оценок)
Ответ:
Maksim24k
Maksim24k
01.05.2020 06:01
Вот:

program pole;
var a, b, c, d, n, kolvo, x, y: real;
begin
write ('За сколько часов топчет землю Нейромонах Феофан? ');
read (a);
write ('За сколько часов топчет землю Балалаечник Никодим? ');
read (b);
write ('За сколько часов топчет землю Косолапый Мишка? ');
read (c);
write ('За сколько часов топчет землю 1 Добрый Молодец? ');
read (d);
write ('За сколько часов нужно выкопать землю? ');
read (n);
x:=1/a+1/b+1/c;
kolvo:=(1/n-x)/(1/d);
if (kolvo<0) then write ('Группа справится без молодцев.') else
begin
y:=kolvo;
if (((trunc(y*10)) mod 10) <5) then
kolvo:=kolvo + 1;
write ('Вот столько вам потребуется добрых молодцев: ', round(kolvo));
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота