Контрольная работа по теме «одномерные массивы», 9 класс. вариант – 1 написать программу для нахождения суммы элементов массива в(20), модуль которых больше 10. написать программу подсчитывающую количество отрицательных и положительных элементов в числовом массиве с(15). найти произведение четных положительных элементов массива а(15).
uses crt;
label 1;
var a: integer;
begin
1: write('Введите азимут в градусах: ');
readln(a);
if a in [1..89] then writeln('Направление: северо-восток');
if a = 90 then writeln('Направление: восток');
if a in [91..179] then writeln('Направление: юго-восток');
if a = 180 then writeln('Направление: юг');
if a in [181..269] then writeln('Направление: юго-запад');
if a = 270 then writeln('Направление: запад');
if a in [271..359] then writeln('Направление: северо-запад');
if a in [0,360] then writeln('Направление: север');
if a > 360 then begin
clrscr;
введите корректное значение.');
goto 1;
end;
if a < 0 then begin
clrscr;
введите корректное значение.');
goto 1;
end;
end.
{Второй вариант}
uses crt;
label 1;
var a: integer;
begin
1: write('Введите азимут в градусах: ');
readln(a);
case a of
0,360: writeln('Направление: север');
1..89: writeln('Направление: северо-восток');
90: writeln('Направление: восток');
91..179: writeln('Направление: юго-восток');
181..269: writeln('Направление: юго-запад');
270: writeln('Направление: запад');
271..359: writeln('Направление: северо-запад');
end;
if a < 0 then begin
clrscr;
введите корректное значение.');
goto 1;
end;
if a > 360 then begin
clrscr;
введите корректное значение.');
goto 1;
end;
end.
// Внимание! Если программа не работает, обновите версию!
№1
begin
var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
Writeln('Заработок работника равен ',624750/(a+k))
end.
Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750
№2
begin
var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
var x:=ReadReal('Мальчик пробежал, км: ');
Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.
Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км: 12
Затрачено времени на бег, ч: 0.77