В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
aleksey778
aleksey778
14.05.2023 23:06 •  Информатика

Кто хорошо понимает информатику-! : используя синтаксис паскаль,составить программу которая,выводит наибольший вес ягод(рассмотреть 5 разных фруктов,вес использовать среднестатистический) мне сказали сделать все это на бумаге. или хотя бы объясните. потому что я ничего не понимаю и не знаю с чего начать.

Показать ответ
Ответ:
eviljew1
eviljew1
06.10.2020 10:19
Const k=5;
var a:array[1..k] of integer;
i,max:integer;
begin
for i:=1 to k do
 begin
 a[i]:=random(10)+20;
 write(a[i]:3);
 end;
writeln;
max:=a[1];
for i:=2 to k do
 if a[i]>max then max:=a[i];
writeln('max = ',max);
end.

Пример:
 26 25 21 25 20
max = 26
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота