В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
marina2770
marina2770
24.02.2021 15:40 •  Информатика

кто может.

1.Определите значение переменной Sum после выполнения фрагмента программы:
i:=0;
Sum:=0;
while i<4 do
begin
i:=i+1;
Sum:= Sum+3*i;
end;

2.Используя цикл while, напишите программу, вычисляющую сумму всех чётных чисел от 1 до введённого целого числа m.

3.Определите, что будет выведено в результате работы программы. Запишите условие задачи, для решения которой составлен алгоритм.

var
m: integer;
begin
m:=154;
while (n mod 16<>0) do
m:=m+1;
writeln (‘M= ’, m);
end.​

Показать ответ
Ответ:
ekatsinrom
ekatsinrom
04.11.2021 00:30

Месяц находим методом половинного деления.

Двоичная запись числа 366 размещается в 9 битах (в 8 битах размещается только 256 чисел , а в 9 битах - уже 512).

То есть , понадобится задать 8 вопросов и девятой фразой будет ответ.

В году 365 (366) дней. Пусть 366, для 365 рассуждение то же.

Рассмотрим самый худший вариант

Середина года - день номер 366/2=183. Это 1 июля.

Первый вопрос: День рождения в первой половине года?

Допустим, да.

Второй вопрос: День рождения в первом квартале?

Допустим, нет. Следовательно во втором.

Второй квартал - это дни с номерами от 92 до 182. Середина - среднее арифметическое. (92+182)/2=137. Это дата 17 мая.

Третий вопрос: День рождения позднее 17 мая?

Допустим, нет.

Следовательно, интервал дат 1 апреля - 17 мая, 91 день. Опять делим на 2, сужая интервал до 22 дней. Это дата 22 апреля.

Четвертый вопрос: День рождения позднее 22 апреля?

Допустим, нет.

Новый диапазон поиска - 23 апреля - 17 мая. Половиним его.

Пятый вопрос: День рождения позднее 29 апреля?

Допустим, нет.

Поиск сузился до 23 - 29 апреля. Снова берем половину.

Шестой вопрос: День рождения позднее 26 апреля?

Допустим, нет.

Интервал дат 23-26 апреля. Половиним.

Седьмой вопрос: День рождения позднее 24 апреля?

Допустим, да.

Интервал дат 25-26 апреля.

Восьмой вопрос: День рождения 25 апреля?

Допустим, нет

Девятая фраза: Ваш день рождения 26 апреля.

0,0(0 оценок)
Ответ:
mariannabatman
mariannabatman
20.08.2020 01:27
Апр,  школа №151 мурманской области вам: 1) 24 буквы + 8 цифр = 32 символа 2) 32 символа + 1 пробел = 33 символа 3) а так как для 32 символов нужно 5 бит, то для 33 символов нужно 6 бит ответ: i = 6 бит 2. здесь каждый раз придется задавать вопросы, чтобы  уменьшить количество возможных вариантов. 1) больше или меньше 32? 2) больше или меньше 16? 3) больше или меньше 8? 4) больше или меньше 4? 5) больше или меньше 2? ответ: 5 вопросов. 3. не смогу . мне задали другое . удачи. 3 уже обеспечена : )
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота