В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
dragons55u
dragons55u
25.02.2020 01:08 •  Информатика

КТО-НИБУДЬ ... Составить программу для решения следующей задачи: Имеется станция автоматической записи температуры и влажности воздуха. Наблюдение ведется в течение месяца. Определить в какой из дней температура воздуха была максимальной, влажность - Минимальной в ответе указать 2 значения для температуры(дату и температуру), для влажности(дату и влажность). Задание Выполнить с использованием массивов, значения температуры и влажности задать случайными числами в диапазоне. Для температуры - от 20 до 38, для влажности от 30 до 85.

Показать ответ
Ответ:
manerov68
manerov68
21.06.2022 15:11
Var
  a, b: real;

begin
  Write('Введите два числа через пробел ');
  Readln(a, b);
  Writeln('Среднее арифметическое кубов равно ', (a * sqr(a) + b * sqr(b)) / 2);
  Writeln('Среднее геометрическое модулей равно ', sqrt(abs(a * b)))
end.

Тестовое решение:
Введите два числа через пробел -13.5 17.43
Среднее арифметическое кубов равно 1417.4722035
Среднее геометрическое модулей равно 15.3396544941534


Замечание: вместо произведения модулей при вычислении среднего геометрического достаточно взять модуль произведения - в любом случае получится требуемое положительное число.
0,0(0 оценок)
Ответ:
daryabazhutina
daryabazhutina
24.12.2020 06:43
Var
  x, a, b, c, y: integer;

begin
  Write('Введите целое трехзначное положительное число ->');
  Readln(x);
  a := x mod 10;
  y := 100 * a + (x div 10);
  Writeln('Первоначальное число было: ', y);
  b := y mod 100;
  Writeln('Зачеркнули первую цифру: ', b);
  b := 10 * b;
  Writeln('Умножили на 10: ', b);
  b := b + (y div 100);
  Writeln('Прибавили зачеркнутую цифру: ', b);
  Writeln('И получили введенное нами число - результат')
end.

Тестовое решение:
Введите целое трехзначное положительное число ->183
Первоначальное число было: 318
Зачеркнули первую цифру: 18
Умножили на 10: 180
Прибавили зачеркнутую цифру: 183
И получили введенное нами число - результат
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота