В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
1domrahev
1domrahev
28.01.2023 22:52 •  Информатика

Лёгкая по паскалю! , ! написать программу которая удаляет все точки і запятые из строки s.

Показать ответ
Ответ:
creativeIgorek
creativeIgorek
04.10.2020 17:59
Решение для одного-двух разных удаляемых символов

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Replace('.','').Replace(',','');
  s.Println
end.

Пример
> Раз, два, три, четыре, пять. Вышел зайчик погулять.
Раз два три четыре пять Вышел зайчик погулять

Решение, когда разных удаляемых символов может быть много

// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>');
  s:=s.Where(с->not(с in [',','.'])).JoinIntoString;
  s.Println
end.
0,0(0 оценок)
Ответ:
Aminabr
Aminabr
04.10.2020 17:59
Pasca
program eazy;
var s:string;
i:integer;
begin
writeln('Vvedite tekst');
readln(s);
for i:=length(s) downto 1 do
if (s[i]=' ') or(s[i]=',') or (s[i]='.') then
delete(s,i,1) ;
writeln(s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота