Люди добрые, решить в pascal. 1) составить программу, которая запрашивает целое двузначное число и на экран выдаёт остаток от деления этого числа на 3.2) за три четверти средний по информатике учащихся 7 классов составил а, b и c соответственно (ввести с клавиатуры). напишите код программы для расчёта среднего за все 3 четверти.(побыстрее, если есть возможность. 20 , )
Объяснение:1.Центра́льный проце́ссор- электронный блок, либо интегральная схема исполняющая машинные инструкции , главная часть аппаратного обеспечения компьютера. Если просто говоря главная штука в кампе.
2.К работе в компьютерном классе допускаются лица данную инструкцию по технике безопасности и правилам поведения, медицинский осмотр и не имеющие противопоказаний по состоянию здоровья;
Работа учащихся в компьютерном классе разрешается только в присутствии преподавателя;
Во время занятий посторонние лица могут находиться в классе только с разрешения преподавателя;
Во время перемен между уроками проводится обязательное проветривание компьютерного кабинета с обязательным выходом учащихся из класса;
3.Джон Мокли, американский физик и инженер.
4.Можно попасть в больницу с ожогами либо умереть.
5.Процессор может сильно нагружаться из за вирусов и програм которые по характеристикам не подходят на ваш компьютер, а вы всёравно пытаетесь запустить мощную програму на слабом компьютере.
namespace Fractions{ public struct Fraction : IComparable<Fraction> { public Fraction(int numerator, int denominator) { Numerator = numerator; Denominator = denominator; }
public int Numerator; public int Denominator;
public int CompareTo(Fraction other) { return (Numerator * other.Denominator).CompareTo(other.Numerator * Denominator); } }
public class Program { static void Main(string[] args) { int numerator, denominator;
Console.Write("Числитель первой дроби "); numerator = int.Parse(Console.ReadLine()); Console.Write("Знаменатель первой дроби "); denominator = int.Parse(Console.ReadLine()); var fraction1 = new Fraction(numerator, denominator);
Console.Write("Числитель второй дроби "); numerator = int.Parse(Console.ReadLine()); Console.Write("Знаменатель второй дроби "); denominator = int.Parse(Console.ReadLine()); var fraction2 = new Fraction(numerator, denominator);
var compareResult = fraction1.CompareTo(fraction2); if (compareResult < 0) Console.WriteLine("<"); else if (compareResult > 0) Console.WriteLine(">"); else // = 0 Console.WriteLine("="); } }}