В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Denis99133
Denis99133
08.02.2023 15:55 •  Информатика

Максимум .
нужно составить программу на паскале (ниже само ).

если хотя бы два числа из трех введенных чисел положительны, то
уменьшить каждое нечетное число на 1, иначе – найти сумму всех
чисел.

Показать ответ
Ответ:
vlinkova4
vlinkova4
07.10.2020 20:34

var a,b,c,kol:integer;

 begin

   readln(a,b,c);

if a>0 then inc(kol);

if b>0 then inc(kol);

if c>0 then inc(kol);

if kol>=2 then

                      begin

                        if a mod 2=1 then dec(a);

                        if b mod 2=1 then dec(b);

                        if c mod 2=1 then dec(c);

                      end

  else writeln(a+b+c);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота