В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
sonyapanferova
sonyapanferova
18.07.2022 18:04 •  Информатика

Манхэттенский проект — кодовое название программы сша по разработке ядерного оружия. в разработке участвовало рекордное количество ученых с мировым именем. вот список наиболее известных из них: энрико ферми, нильс бор, джон фон нейман, ричард фейнман, роберт оппенгеймер, ганс бизе, ханс бете. вам было поручено написать программу-пропуск, которая принимает на вход имя человека и выводит "доступ разрешен", если имя присутствует в списке, представленном выше, или "доступ запрещен" в обратном случае.

нужно использовать переменную elif

Показать ответ
Ответ:
mixon2
mixon2
16.11.2022 15:09
Pascal:
1)
const n = 10;
var a:array [1..n] of integer;
     i:integer;
begin
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    write (a[i]:3);
   end;
  writeln;
  for i:=1 to n do
   begin
    if a[i]>0 then a[i]:=99;
    write (a[i]:3);
   end;
  writeln;
end.

2)
const n = 10;
var a:array [1..n] of integer;
     p,s,i:longint;
begin
  p:=1;
  s:=0;
  randomize;
  for i:=1 to n do
   begin
    a[i]:=random(21)-10;
    if a[i]>0 then p:=p*a[i] else
     if a[i]<0 then s:=s+a[i];
    write(a[i]:3);
   end;
  writeln;
  writeln ('Proizvedenie: ',p);
  writeln ('Summa: ',s);
end.

C++:
1)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      a[i] = 99;
  }
  cout <<endl;
  for (int i = 0; i<10; i++)
    cout <<a[i] <<" ";
  cout <<endl;
  return 0;
}

2)
#include <iostream>
#include <ctime>
#include <cstdlib>
using namespace std;

int main()
{
  int a[10];
  int p = 1,s = 0;
  srand (time(NULL));
  for (int i = 0; i<10; i++)
  {
    a[i] = rand()%20-10;
    cout <<a[i] <<" ";
    if (a[i]>0)
      p*=a[i];
    else if (a[i]<0) s+=a[i];
  }
  cout <<endl;
  cout <<"Summa: " <<s <<endl
         <<"Proizvedenie: " <<p <<endl;
  return 0;
}
0,0(0 оценок)
Ответ:
Маха1437
Маха1437
24.12.2021 10:36
Средняя глубина Черного моря — 1271 м, наибольшая- 2245 метров (вблизи Синопа). Протяженность моря между западной и восточной точками —около 1167 км, между северной и южной-624 километра. Наименьшая протяженность акватории в меридиональном направлении, между Крымом и берегом Анатолии (азиатской части Турции), 263 км. Длина береговой линии Черного моря — 4090 км, коэффициент изрезанности — около 1,8.На площади, занятой Черным морем, можно разместить две Великобритании. Азовское море соединяется с Чёрным морем Керченским проливом. Площадь его — около 38000 кв. км. Преобладающие глубины — 9-13 м, наибольшая — 14,5 м. Берега изрезаны слабо. Крупнейший залив - Таганрогский; у западного берега - система мелких заливов Сиваш. Южный берег моря холмистый, для северного и северо-восточного берегов характерны косы. В Азовское море впадают реки Дон, Кубань и другие, образуя лиманы. Климат континентальный, средняя температура воздуха летом +23?-24?, зимой -7 ?С. С конца декабря до конца февраля покрывается льдом. Течения неустойчивы. Вода отличается мутностью, море богато рыбой: судак, лещ, кефаль, осётр, и т. д. Главные порты: Ростов-на-Дону, Таганрог, Азов.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота