В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Rr0
Rr0
26.10.2020 21:23 •  Информатика

Массив из 7 элементов введите с клавиатуры. Найти небольшой элемент в массиве и выведите значение на экран. Выведите на экран все элементы массива в столбик

Показать ответ
Ответ:
NetBPeMeHu
NetBPeMeHu
03.04.2021 22:42

Відповідь:

#include <iostream>

using namespace std;

const int size = 10;

void cinarr(int *arr,const int size){

int counter = 1;

for(int i = 0; i < size; i++){

 cout << "Введите " << counter << " елемент массива: ";

 cin >> arr[i];

 counter++;

}

}

void printarr(int *arr, const int size){

for(int i = 0; i < size; i++){

 cout << arr[i] << " ";

}

}

int expression(int *arr,const int size,int number){

int counternumber = 0;

for(int i = 0; i < size; i++){

 if(number == arr[i]){

  counternumber++;

 }

}

return counternumber;

}

int main(){

setlocale(LC_ALL , "Rus");

int number;

cout << "Введите число которое будем искать: ";

cin >> number;

int *arr = new int [size];

cinarr(arr,size);

printarr(arr,size);

cout << "\nТаких чисел в массиве: " << expression(arr,size,number) << endl;;

delete [] arr;

return 0;

}

Пояснення:


Написать программу, которая получает на 10 элементов и записывает их в массив. Также программа получ
0,0(0 оценок)
Ответ:
yoanna0900
yoanna0900
30.07.2020 08:43

целые числа), перемещающую Чертёжника из точки c координатами (x, y) в точку с координатами (x + a, y + b). Если числа a, b положительные, значение соответствующей координаты увеличивается; если отрицательные – уменьшается. Например, если Чертёжник находится в точке с координатами (9, 5), то команда Сместиться на (1, –2) переместит Чертёжника в точку (10, 3).  

Запись  

Повтори k раз  

Команда1 Команда2 Команда3  

конец  

означает, что последовательность команд Команда1 Команда2 Команда3  

повторится k раз.  

Чертёжнику был дан для исполнения следующий алгоритм:  

Повтори 3 раз  

Сместиться на (–2, –3) Сместиться на (3, 2) Сместиться на (–4, 0)  

конец  

На какую одну команду можно заменить этот алгоритм, чтобы Чертёжник оказался в той же точке, что и после выполнения алгоритма?  

1) Сместиться на (–9, –3)  

2) Сместиться на (–3, 9)  

3) Сместиться на (–3, –1)  

4) Сместиться на (9, 3)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота