В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Массив констант содержит информацию о месяцах рождения 10 учащихся класса . Составьте программу , вычисляющую ( попросили найти не только сколько зимой , но и сколько летом родилось, кого больше родилось летом или зимой Pascal abc


Массив констант содержит информацию о месяцах рождения 10 учащихся класса . Составьте программу , вы

Показать ответ
Ответ:
какулькаТВ
какулькаТВ
18.10.2021 08:50

const

a : array[1..10] of integer = (12, 5, 4, 1, 9, 7, 8, 2, 3, 2);

var k, _counterW, _counterS: integer;

begin

_counterS := 0;

_counterW := 0;

for k := 1 to 10 do

   begin

   if (a[k] = 12) or (a[k] = 1) or (a[k] = 2) then

       _counterW := _counterW + 1

   else if (a[k] = 6) or (a[k] = 7) or (a[k] = 8) then

       _counterS := _counterS + 1;

   end;

writeln('Количество родившихся летом:', _counterS);

writeln('Количество родившихся зимой:',_counterW);

if _counterW > _counterS then

   writeln('Зимой родилось большее количество учащихся!')

else if _counterS > _counterW then

   writeln('Летом родилось большее количество учащихся!')

else

   writeln('Летом и зимой родилось одинаковое число учащихся!');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота