Массив содержит информацию о стоимости 20 товаров в магазине (случайные числа от 1 до 50). С клавиатуры вводятся коли-
чество товаров, которые приобретает покупатель, и номера приобрета-
емых товаров. Составьте программу для нахождения стоимости по-
купки.
n=5;
Var
ar:array[1..n] of integer;
ar2:array[1..n] of integer;
i,k:integer;
function prost(a:integer):boolean;
var i:integer;
b:boolean;
begin
b:=true;
for i:=2 to a div 2 do
if a mod i=0 then
begin;
b:=false;
break;
end;
if a=1 then b:=false;
prost:=b;
end;
begin;
randomize;
k:=0;
for i:=1 to n do
begin;
ar[i]:=random(101);
write(ar[i]:4);
end;
writeln;
for i:=1 to n do
if prost(ar[i]) then
begin;
inc(k);
ar2[k]:=ar[i];
write(ar2[k]:4);
end;
end.
t: integer;
begin writeln('введите х и у');
readln(x,y);
z:=sqrt(sqr(x)-sqr(y));
t:=0;
while (z>0,1) do
begin t:=t+1;
z:=0,98*z; {если 2% от изменяющегося расстояния до пола;
если же имеется ввиду 2% от исходного расстояния,
то нужно будет ввести новую переменную
или присвоить исходное значение z, например х,
то есть сразу после z:=sqrt(sqr(x)-sqr(y)); написать x:=z;
Формула (оператор) z:=0,98*z; изменится так:
z:=z-x*0,98}
end;
writeln('палка упадет через ', t,' мин.');
end.