В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Массив содержит информацию об отметках по информатике 20 учащихся класса.Отметки вводятся с клавиатуры.Составьте программу ,которая вычисляет средний по предмету и количество учащихся с отметками выше среднего .

Показать ответ
Ответ:
liudmilka19091982
liudmilka19091982
18.10.2020 05:52
Алг а1
нач
   вещ первое, второе
   ввод первое, второе
   вывод первое/второе
кон

Тестовое решение:
>> 01:12:23 - Новая программа* - Выполнение начато
16.5 3
5.5
>> 01:12:34 - Новая программа* - Выполнение завершено

алг а2
нач
   цел число1, число2, число3, произведение
   ввод число1, число2, число3
   произведение:= число1*число2*число3
   если произведение <50 то
       вывод 10*число1,", ",10*число2,", ",10*число3
       иначе вывод произведение
   все
кон

Тестовое решение:
>> 01:18:48 - Новая программа* - Выполнение начато
4 2 3
40, 20, 30
>> 01:18:59 - Новая программа* - Выполнение завершено

>> 01:20:19 - Новая программа* - Выполнение начато
5 6 7
210
>> 01:20:23 - Новая программа* - Выполнение завершено
0,0(0 оценок)
Ответ:
4ev43yi3
4ev43yi3
24.10.2020 04:53
Const
n1=1000;
m1=1000;
var
n,m,i,j,min,max,i_max:integer;
a:array[1..n1,1..m1]of integer;
    begin
        writeln('введите кол строк и столбцов');
         readln(n,m);
             for i:=1 to n do
                 for j:=1 to m do
                      readln(a[i,j]);
for i:=1 to n do
    begin
        writeln;
              for j:=1 to m do
                    write(a[i,j]:4);
    end;
max:=-32767;
for i:=1 to n do
    begin
        min:=a[i,1];
           for j:=1 to m do   
                if a[i,j]<min then
                   min:=a[i,j];
         if min>max then
              begin
                   max:=min;
                   i_max:=i;
              end;
      end;
writeln;
writeln('i: ',i_max,'    znach: ',max);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота