В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
wonderr
wonderr
28.05.2023 08:02 •  Информатика

Массив состоит из 5 элементов. Элементы массива вводятся с клавиатуры. Это числа 12, 15, 30, 5, 7. Напишите программу, которая вычислит сумму чисел, которые больше 9 и кратны 5.
Программа должна вывести на экран одно число: сумму элементов массива, которые больше 9 и кратны 5.

Показать ответ
Ответ:
Илончик10
Илончик10
07.01.2021 07:47

#include <iostream>

using namespace std;

long long a[6], i, sum = 0;

int main()

{

   cin >> a[0] >> a[1] >> a[2] >> a[3] >> a[4];

   for(i = 0; i < 5; i++)

       if(a[i] > 9 && !(a[i] % 5))

           sum+=a[i];

   cout << sum << endl;

   return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота