В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
gigi24
gigi24
07.04.2020 16:52 •  Информатика

Массивы

1. В программе используется одномерный целочисленный массив A с индексами от 0 до 9. Значения элементов равны 5; 1; 6; 7; 8; 8; 7; 7; 6; 9 соответственно, т. е. A[0] = 5; A[1] = 1 и т. д. Определите значение переменной c после выполнения следующего фрагмента программы, записанного ниже на разных языках программирования.

аскаль Алгоритмический язык

c := 0;

for i := 1 to 9 do

if A[i - 1] >= A[i] then

begin

t := A[i];

A[i] := A[i - 1];

A[i - 1] := t

end

else

c := c + 1; c := 0

нц для i от 1 до 9

если A[i - 1] >= A[i] то

t := A[i]

A[i] := A[i - 1]

A[i - 1] := t

иначе

c := c + 1

все

кц

Показать ответ
Ответ:
nastyapuhova1
nastyapuhova1
08.10.2020 02:29

#inclued<bits/stdc++.h>

using namespace std;

int main()

{int d,m;

cin>>d>>m;

if (m==1)

{if (d>=20)

cout<<"vodoleey";

else cout<<"kozerog";}

if (m==2)

{if (d>=19)

cout<<"ribi";

else cout<<"vodoley";}

if (m==3)

{if (d>=21) cout<<"oven";

else cout<<"ribi";}

if (m==4)

{if (d>=20)

cout<<"telec";

else cout<<"oven";}

if (m==5)

{if (d>=21)

cout<<"blizneci";

else cout<<"telec";}

if (m==6)

{if (d>=22)

cout<<"rac";

else cout<<"blizneci";}

if (m==7)

{if (d>=23)

cout<<"lev";

else cout<<"rac";}

if (m==8)

{if (d>=23)

cout<<"deva";

else cout<<"lev";}

if (m==9)

{if (d>=23) cout<<"vesi";

else cout<<"deva";}

if (m==10)

{if (d>=23)

cout<<"scorpion";

else cout<<"vesi";}

if (m==11)

{if (d>=23)

cout<<"strelec";

else cout<<"scorpion";}

if (m==12)

{if(d>=22)

cout<<"kozerog";

else cout<<"strelec";}

return 0;

}

0,0(0 оценок)
Ответ:
zlatochkagr
zlatochkagr
15.11.2022 07:10
Ведь под знаком принято понимать цифры и числа, буквы и слова человеческого языка. А то, что от первого взгляда на глиняную табличку рябит в глазах от треугольных элементов ещё не значит, что всё так однозначно.
"...Старейшая из известных систем письма – клинопись (т. е. клинообразное письмо, англ. cuneiform от латинского cuneus "клин") возникла не позже 3100 до н. э. и находилась в употреблении примерно до начала нашей эры. Сначала клинописное письмо было в ходу у шумеров – народа с высокоразвитой культурой, но с неизвестными этническими и языковыми корнями.. .Ее использовали для записи своих собственных языков хетты в Анатолии, хурриты, жившие на территории современной Сирии и северного Ирака, эламцы на западе Ирана и урартцы в Армении.. .Число знаков в клинописи менялось в течение всей ее истории, но примерно их было всего 600, из них 100–150 были слоговыми знаками... "
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота