Методика выполнения работы 1. программа имеет линейную структуру в соответствии с алгоритмом на рис. 5.2. s1 – блок ввода исходных данёных a, b, c. s2 – блоки расчета полупериметра треугольника p и площади s. s3 – блок вывода результата: площадь s. введите программу решения этой (см. пп. 1-3, лабораторная работа № 1). program geron; uses crt; var a,b,c,p,s: real; begin clrscr; {ввод исходных данных} writeln(‘введите значения сторон треугольника a,b,c’); readln(a,b,c); {расчет полупериметра и площади треугольника} p: = 0.5*(a+b+c); s: =sqrt(p*(p-a)*(p-b)*(p-c)); {вывод результата расчета} writeln(‘площадь треугольника = ’, s: 5: 3) end. 2. откомпилируйте программу и исправьте возможные ошибки. затем запустите программу на счет (см. пп. 4-5, лабораторная работа № 1). 3. проведите тестовый расчет, чтобы убедиться в правильности работы программы. введите значения сторон: a=1, b=1, c=1. должен получиться результат s=0.433. 4. проведите серию расчетов для различных значений сторон треугольника. 5. если значения сторон являются константами (например, все равны 1), то в данную программу можно ввести следующие изменения: перед разделом var надо добавить раздел констант – const a=1; b=1; c=1; из раздела var убрать a,b,c – var p,s: real; убрать ввод исходных данных – удалить операторы writeln(‘введите…’); readln(a,b,c); 6. сделайте указанные исправления и повторите пп. 1-3 данной работы. для самостоятельной работы составить программу на языке паскаль для нахождения значения выражения. константы a, b, c вводятся с клавиатуры. сложные аргументы функций вычислять отдельно, tan(x) вычислять как sin(x)/cos(x), ctan(x) → cos(x)/sin(x), xy → exp(y*ln(
Панель управления (англ. Control Panel) является частью пользовательского интерфейса Microsoft Windows. Она позволяет выполнять основные действия по настройке системы, такие, как добавление и настройка устройств, установка и деинсталляция программ, управление учётными записями, включение специальных возможностей, а также многие другие действия, связанные с управлением системой. Апплеты (значки) Панели управления, с которых можно выполнять определенные системные действия, представляют собой файлы с расширением .cpl. Большинство таких файлов расположено в системных папках C:\Windows\System32 и C:\Windows\winsxs (в папках внутри этой папки). Каждый такой апплет запускает системную утилиту, которая выполняет соответствующее действие, связанное с настройкой либо управлением операционной системой. Большинство апплетов в Панели управления соотносятся с определенными системными утилитами производства Microsoft, но в некоторых случаях сторонние производители также добавляют свои значки в Панель управления Windows 7 для достижения большего удобства управления своим программным либо аппаратным продуктом. Впервые Панель управления появилась в Windows 2.0. Многие из ныне существующих апплетов были добавлены с новыми релизами операционной системы. Со временем апплетов стало достаточно много, и это послужило поводом для сортировки их по категориям. Теперь пользователь волен самостоятельно выбирать наиболее удобный для него режим просмотра.2
Параметры функции main () служат для передачи программе аргументов командной строки, т. е. имен файлов, ключей, опций и вообще всего, что вы вводите с клавиатуры после подсказки DOS, запуская программу.3.
Компиля́тор – это программа, которая переводит текст, написанный на языке программирования, в набор машинных кодов.. ..,
4
Отла́дчик (англ. debugger от bug, баг) — компьютерная программа для автоматизации процесса отладки: поиска ошибок в других программах, ядрах операционных систем, SQL-запросах и других видах кода. В зависимости от встроенных возможностей, отладчик позволяет выполнять трассировку, отслеживать, устанавливать или изменять значения переменных в процессе выполнения кода, устанавливать и удалять контрольные точки или условия остановки и так далее.
5.Незнаю(=) если с чем то то
Объяснение:
Программа:
Pascal:
var
chemodan, klad, dop: real;
begin
write('Вес чемодана', #10, '<<< '); readln(chemodan);
write('Вес ручной клади', #10, '<<< '); readln(klad);
write('Вес доп. предметов ручной клади', #10, '<<< '); readln(dop);
writeln('Вес багажа: ', chemodan + klad + dop);
end.
Python:
chemodan = float(input('Вес чемодана\n>>> '))
klad = float(input('Вес ручной клади\n>>> '))
dop = float(input('Вес доп. предметов ручной клади\n>>> '))
print('Вес багажа:', chemodan + klad + dop)