Методы вычисление Матлаб. Составить программу, которая в каждой строке матрицы Z(m, n), m<10,
nS12 находит элемент, для которого модуль разности элемента и среднего геометрического модулей всех элементов строки максимален. Предполагается, что матрица нулевых элементов не содержит. Вывести матрицу в виде матрицы, располагая рядом с каждой строкой найденный элемент и модуль искомой разности.
КАК ЭТО РЕШАТЬ, УЖЕ НЕДЕЛЮ ГОЛОВУ ЛОМАЮ. Нужно решить через Матлаб. Объясните как это сделать, кто разбирается очень вас.
var x1, y1, x2, y2, n1, n2: real;
begin
write('x1, y1: ');
read(x1, y1);
write('x2, y2: ');
read(x2, y2);
n1:= sqrt(sqr(x1)+sqr(y1));
writeln(n1);
n2:= sqrt(sqr(x2)+sqr(y2));
writeln(n2);
if n1<>n2 then
if n1<n2 then
writeln('1 точка находится ближе к началу координат.')
else
writeln('2 точка находится ближе к началу координат.')
else
writeln('Точки находятся на равном расстоянии от начала координат.')
end.
3.)
var n, x, a, b, c, s: integer;
beginwrite('Введите число: ');
readln(n);
if (n>99) and (n<1000) then
begin
write('Введите x: ');
readln(x);
a:= n div 100;
b:= (n - a*100) div 10;
c:= (n - a*100 - b*10);
if a=x then s:=s+1;
if b=x then s:=s+1;
if c=x then s:=s+1;
if s>0 then
writeln('В числе есть ', x)
else writeln('В числе нет ', x);
end
else
writeln('Число не трехзначное');
end.
165 стр.
Объяснение:
мороженое & ( пирожное | шоколад ) = 427 стр.
мороженое & пирожное = 262 стр.
мороженое & пирожное & шоколад = 61 стр.
мороженое & ( пирожное | шоколад ) =
(мороженое & пирожное) | (мороженое & шоколад)
Кол-во стр. (мороженое & пирожное) | (мороженое & шоколад) минус кол-во стр. мороженое & пирожное равно кол-во стр. мороженое & шоколад. Значит, кол-во стр. мороженое & шоколад равно 427-262=165 стр.
(На картинке иллюстрация этих множеств)