Мне нужна : в фрее паскаль рассмотрим массив t [1..n] целых чисел, где n < = 20. напишите программу, используя процедуру, которая будет отображать положительные элементы этого массива.мне нужно под этот модель : этот програм считает сумму. type tab=array[1..10] of integer; var a: tab; i,n: integer; s: real; procedure suma(var x: tab; n: integer; var sum: real); var i: integer; begin sum: =0; for i: =1 to n do sum: =sum+x[i]; end; begin{main} write('n='); readln(n); write('dati elementele tabloului: '); for i: =1 to n do readln(a[i]); suma(a,n,s); write('s=',s: 7: 2); end. заранее.
Ну как-то так, в фрипаскале работает