мне нужно написать программу на языке pascalabcnet чтобы спрашивалась переменная x
q должно быть равно 1/100000 от x
w 1/10000 x
e 1/1000 x
r 1/100 x
t 1/10 x
y остаток от x/10
и чтобы программа проверяла если q+w+e = r+t+y
то программа пишет да
иначе программа напишет нет
короче это программа узнаёт счастливый билет или нет
билет является счастливым если сумма первых трёх цифр равняется сумме 4 5 6 цифр
#include<cstdlib>
#include<ctime>
#define abs(x) ((x)<0 ? -(x) : (x))
using namespace std;
int main()
{
srand(time(0));
int n, k, m = 0;
cout << "n = ", cin >> n;
int A[n], B[n];
cout <<"A("<<n<<"):";
for(int i = 0; i < n; i++)
cout <<" "<< (A[i] = rand() % (n*2+1) -n);
cout << "\nk = ", cin >> k;
for(int i = 0; i < n; i++)
if (abs(A[i]) % 10 == k) B[m++] = A[i];
cout <<"B("<<m<<"):";
for(int i = 0; i < m; i++)
cout <<" "<< B[i];
return 0;
}