Можите дать пояснение к этому коду и почему он не работает?
ЗАДАНИЕ В С++ В массиве хранится информация о стоимости книг . Составить программу, которая выводит на экран номера книг, которые стоят ниже средней стоимости всех этих книг.
#include
using namespace std;
#define ll long long
#define ld long double
signed main(){
ll n;
cin >> n;
ld a[n],sum = 0;
for(ll i = 0; i < n; i++){
cin >> a[i];
sum += a[i];
}
ld av = sum/n;
for(ll i = 0; i < n; i++)
if(a[i] < av)
cout << i+1 << " ";
}
Відповідь:
Сложная тема в пояснении все что нужно написать
Пояснення:
Основные направления развития информационной безопасности кредитно-финансовой
сферы на период 2019–2021 годов (далее – Основные направления) определяют ключевые
цели и задачи развития информационной безопасности и киберустойчивости, среди которых:
• обеспечение информационной безопасности и киберустойчивости в целях финансовой
стабильности каждой организации финансового рынка;
• обеспечение операционной надежности и непрерывности деятельности организаций кредитно-финансовой сферы;
• противодействие компьютерным атакам, в том числе при использовании инновационных
финансовых технологий;
• защита прав потребителей финансовых услуг.
Основные направления включают описание предпосылок и трендов в развитии информационной безопасности кредитно-финансовой сферы Российской Федерации, задачи и ключевые направления деятельности Банка России в области информационной безопасности и киберустойчивости, а также описание мероприятий в указанной области.
Мероприятия, предусмотренные Основными направлениями, разработаны в том числе в целях реализации комплекса отдельных задач в рамках федеральных проектов национальной
программы «Цифровая экономика Российской Федерации», утвержденных протоколом заседания президиума Правительственной комиссии по цифровому развитию, использованию информационных технологий для улучшения качества жизни и условий ведения предпринимательской деятельности от 06.05.2019 №8.
Код на C++ (компилятор msvc, но на g++ тоже будет работать, если надо)
#include <iostream>
using namespace std;
int main()
{
int left, right;
cin >> left >> right;
if (left > right)
{
swap(left, right);
};
for (int i = left; i <= right; i++)
{
cout << i * i << " ";
};
cout << endl;
return 0;
}
Объяснение:
Тут выводятся квадраты чисел в диапазоне [left;right]. И если так получилось, что left больше right, то мы меняем значения местами