В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Можно ли написать программу для Удвоителя, которая из любого числа x строит число 7x+9?Почему?

Заполните пропуск: «Можно написать программу для Удвоителя, которая из любого числа x строит число a·x+b, где a и b

Показать ответ
Ответ:
Ксюха12111
Ксюха12111
20.07.2022 02:00

Так как язык не указан, приведу пример на SWI-Prolog.

Код:

read_int(Int) :- read(Int), integer(Int).split_int_by_numbers(0, []) :- !.split_int_by_numbers(N, [Number|Ints]) :- Number is mod(N, 10), RestN is div(N, 10), split_int_by_numbers(RestN, Ints).test_to_div(_, []).test_to_div(N, [Number|Ints]) :- mod(N, Number) =:= 0, test_to_div(N, Ints). test(Int) :- split_int_by_numbers(Int, Numbers), test_to_div(Int, Numbers), write(Int), write(" - Yes!"), nl.test(Int) :- write(Int), write(" - No!"), nl.?- read_int(Int), test(Int).
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
0,0(0 оценок)
Ответ:
merhanoooI
merhanoooI
16.01.2022 09:44
Procedure TForm1.Button1Click(Sender: TObject);
begin
    If FontDialog.Execute then
        RichEdit1.SelAttributes.Assign(FontDialog1.Font);
        RichEdit1.SetFocus;
    End;
end;

делфи у меня не установлены за совершенной ненадобностью, потому проверить возможности нет, но догадки показать могу.
 Не уверенна что RichEdit1.SelAttributes.Assign(FontDialog1.Font) выставляет шрифт, может там нужна кострукция типа
  RichEdit1.SelAttributes.Font := FontDialog1.Font
и конечно описка выделенная ранее, как на нее только компилятор не матерится
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота