В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dgafar27oy9omz
dgafar27oy9omz
25.01.2020 18:45 •  Информатика

На ! 1. написать программу которая будет выводить сумму четных цифр(пока не введете 0). 2.программа выводит количество четных цифр. 3.программу которая будет выводить произведение введенных чисел пока не будет введен 0.

Показать ответ
Ответ:
Aleusand
Aleusand
07.10.2020 08:38
// PascalABC.NET 3.3, сборка 1583 от 25.11.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Sum)
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
2708

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Where(t->t.IsEven).Count)
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
5

begin
  Writeln(ReadSeqIntegerWhile(t->t<>0).Aggregate(Biginteger(1),(x,y)->x*y))
end.

Пример
-65 973 571 -101 426 326 207 -85 850 551 713 340 766 0
-775118121479521866390147967800000
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота