В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
BonYseT
BonYseT
09.08.2020 13:17 •  Информатика

На что можно заменить random 5 и уберите randomiz в это программе. нужно !
program massiv_10;
var
a: array[1..10] of integer;
i: integer;
max: integer;
k: integer
begin
randomize;
for i: =1 to 10 do
a[i]: =random(5);
for i: =1 to 10 do
writeln('a[', i, '] a [i]);
max: =a[1];
for i: =2 to 10 do
if a[i]> max then max: =a[i];
writeln ('max=', max);
k: =0
for i: =1 to 10 do
if a[1]= max then k: =k+1
writeln ('k=', k);
end. ​

Показать ответ
Ответ:
ValeriaChernysheva
ValeriaChernysheva
24.02.2023 04:00
Ms dos qbasic 1.0: cls randomize timer input "k = ", k input "l = ", l dim x! (k, l) for i = 1 to k       for j = 1 to l               x(i, j) = rnd * 21 - 10               print using "###"; x(i, j);               print ; " ";       next j       print next i for i = 1 to l * 4 - 1       print ; "_"; next i print for n = 1 to l       for i = 1 to l - n - 1               if x(i, 2) < x(i + 1, 2) then               b = x(i, 2)               x(i, 2) = x(i + 1, 2)               x(i + 1, 2) = b               end if       next i next n for i = 1 to k       for j = 1 to l               print using "###"; x(i, j);               print " ";       next j       print next i end
0,0(0 оценок)
Ответ:
Сарфароз03
Сарфароз03
23.01.2021 23:23

Так как язык не указан, приведу пример на SWI-Prolog.

Код:

read_int(Int) :- read(Int), integer(Int).split_int_by_numbers(0, []) :- !.split_int_by_numbers(N, [Number|Ints]) :- Number is mod(N, 10), RestN is div(N, 10), split_int_by_numbers(RestN, Ints).test_to_div(_, []).test_to_div(N, [Number|Ints]) :- mod(N, Number) =:= 0, test_to_div(N, Ints). test(Int) :- split_int_by_numbers(Int, Numbers), test_to_div(Int, Numbers), write(Int), write(" - Yes!"), nl.test(Int) :- write(Int), write(" - No!"), nl.?- read_int(Int), test(Int).
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
Напишите программу: С клавиатуры вводится трёхзначное число (число десятков и число единиц не равна
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота