В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

На циклы. составить программу в ! ! 3. однажды умный бедняк попросил у скупого богача приюта на две недели, причем сказал: «за это я заплачу тебе в первый день 1 рубль, во второй - 2, в третий -3 и т.д., но ты будешь мне подавать милостыню: в первый день 1 копейку, во второй -2, в третий-4 и т.д. увеличивая милостыню каждый день вдвое». богач с радостью согласился. сколько барыша принесла эта сделка богачу?

Показать ответ
Ответ:
misha22656
misha22656
14.06.2020 13:18

program zadanie;
var
i, n: integer;
bednyak, bogaty: real;
begin
bednyak:=0;
bogaty:=1;
n:=1;
for i:=1 to 14 do
begin
bednyak:=bednyak+1;
bogaty:=bogaty+n;
n:=n*2;
end;
bogaty:=bogaty/100;
writeln('Заплатил бедняк богачу (рублей): ', bednyak);
writeln('Заплатил богач бедняку (рублей): ', bogaty);
writeln('ответ: Богач заплатил бедняку на ', bogaty, ' рублей больше');
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота