На каждую отдельный полный код для pascal. можно без объяснения. заранее за полное решение
1) на плоскости дан набор точек с целочисленными координатами. необходимо найти треугольник наибольшей площади с вершинами в этих точках, одна из сторон которого лежит на оси ox. напишите эффективную, в том числе по памяти, программу, которая будет решать эту . размер памяти, которую использует ваша программа, не должен зависеть от длины переданной последовательности чисел. укажите используемый язык программирования и его версию.
в первой строке вводится одно целое положительное число – количество точек n. каждая из следующих n строк содержит два целых числа – сначала координата х, затем координата у очередной точки.
программа должна вывести одно число – максимальную площадь треугольника, удовлетворяющего условиям . если такого треугольника не существует, программа должна вывести ноль.
пример входных данных:
6
0 0
2 0
0 4
3 3
5 5
-6 -6
пример выходных данных для выше примера входных данных:
6
2) на плоскости дан набор точек с целочисленными координатами. необходимо найти такой треугольник наибольшей площади с вершинами в этих точках, у которого нет общих точек с осью оу, а одна из сторон лежит на оси ох.
напишите эффективную, в том числе по памяти, программу, которая будет решать эту . размер памяти, которую использует ваша программа, не должен зависеть от количества точек.
перед текстом программы кратко опишите используемый алгоритм решения и укажите используемый язык программирования и его версию.
описание входных данных
в первой строке вводится одно целое положительное число - количество точек n.
каждая из следующих n строк содержит два целых числа - сначала координата х, затем координата у очередной точки. числа разделены пробелом.
описание выходных данных
программа должна вывести одно число - максимальную площадь треугольника, удовлетворяющего условиям . если такого треугольника не существует, программа должна вывести ноль.
пример входных данных:
8
-10 0
2 0
0 4
3 3
7 0
5 5
4 0
9 -9
пример выходных данных для выше примера входных данных:
22.5
3) на плоскости задано множество точек с целочисленными координатами. необходимо найти количество отрезков, свойствами:
1. оба конца отрезка принадлежат заданному множеству;
2. ни один конец отрезка не лежит на осях координат;
3. отрезок пересекается с обеими осями координат.
напишите эффективную по времени и по используемой памяти программу для решения этой .
программа считается эффективной по времени, если при увеличении количества точек в k раз время работы возрастает не более чем в k раз.
программа считается эффективной по памяти, если размер памяти для хранения всех необходимых данных не зависит от количества точек и не превышает 1 килобайта.
перед текстом программы кратко опишите алгоритм решения и укажите язык программирования и его версию.
входные данные
в первой строке задаётся n – количество точек в заданном множестве. каждая из следующих строк содержит два целых числа x и y – координаты очередной точки. гарантируется, что 1≤n≤1; -1000≤x,y≤1000.
пример входных данных:
4
6 6
-8 8
-9 -9
7 -5
выходные данные
необходимо вывести единственное число: количество удовлетворяющих требованиям отрезков.
пример выходных данных для выше примера входных данных:
2
4) на плоскости задано множество точек с целочисленными координатами. необходимо найти максимально возможную площадь невырожденного (т.е. имеющего ненулевую площадь) треугольника, одна вершина которого расположена в начале координат, а две другие лежат на осях координат и при этом принадлежат заданному множеству. если такого треугольника не существует, необходимо вывести соответствующее сообщение.
напишите эффективную, в том числе по используемой памяти, программу для решения этой .
перед текстом программы кратко опишите алгоритм решения и укажите язык программирования и его версию.
входные данные
в первой строке задаётся n – количество точек в заданном множестве. каждая из следующих строк содержит два целых числа x и y – координаты очередной точки.
пример входных данных:
3
6 0
0 8
9 7
выходные данные
если искомый треугольник существует, программа должна напечатать одно число: максимально возможную площадь треугольника, удовлетворяющего условиям. если искомый треугольник не существует, программа должна напечатать сообщение: «треугольник не существует».
1) Это книгопечатальщики. Раньше книги приходилось печатать чуть ли не ни в ручную. технологии не позволяли ((( а сейчас благодаря информ. технологиям и инф.обществу делать это стало довольно просто.
2) Инженеры. Раньше инженеры вручную чертили таблицы, схемы макеты зданий. а теперь благодаря инф.обществу делают это всё на компах. и тюд
3)Машиностоители. Благодаря инф. обществву с каждым годом модернезируется производство, а значит станки легки в обращении.
Иформационное общество - это то без чего обойтись нельзя. Вот например тот же интернет. В сети можно читать газеты а не покупать их. и не тратить деньги.
В паскале
1) program one;
uses crt;
var a:array [1..10] of integer;
x: real; i:integer;
begin
clrscr;
x:=0;
for i:=1 to 10 do
readln(A[i]);
for i:=1 to 10 do
begin
if (A[i]<0) or (A[i] mod 2=0) then
x:=x+Sqr(A[i]);
end;
writeln;
write(x);
end.
2)
program two;
uses crt;
var a:array [1..52] of integer;
x,i: integer;
begin
clrscr;
x:=34;
for i:=1 to 52 do
begin
A[i]:=1+x;
x:=x+1;
if (A[i] mod 7 =1)or (A[i] mod 7 =2) or (A[i] mod 7 =5)
then writeln(A[i]);
end;
end.
3)
Program three;
Uses crt;
var n,x:integer; a,y:real;
begin
Clrscr;
readln(a,n);
for x:=1 to n do
y:=x*a;
writeln(y);
end.
4)
Program four;
Uses crt;
var A:array [1..100] of integer;
n,i,max,x:integer;
begin
clrscr;
writeln('vvedite kol-vo elementov');
readln(n);
writeln('Vvedite elementy');
for i:=1 to n do
read(A[i]);
for i:=1 to n do
begin
max:=A[1];
if (A[i] <0) and (A[i]>A[x])
then max:=A[i];
x:=i;
end;
writeln ('Naib',max,'nomer',x);
end.
5)
Program abc;
Uses crt;
var S,a,b:integer;
begin
clrscr;
S:=0;
a:=1;
b:=3;
while a<98 do
begin
while b<100 do
begin
S:=S+b-a;
a:=a+4;
b:=b+4;
end;
end;
writeln(s);
end.