В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
qwaszxpolkmn129
qwaszxpolkmn129
30.01.2020 23:12 •  Информатика

На обработку поступает натуральное число, не превышающее 10°. Нужно написать программу.
которая выводит на экран минимальную чётную цифру этого числа. Если в числе нет чётных цифр, требуется
на экран вывести «NO». Программист написал программу неправильно. Ниже эта программа для Вашего
удобства приведена на трех языках программирования.
На паскале, но могу и бейсик с с++ скинуть​


На обработку поступает натуральное число, не превышающее 10°. Нужно написать программу.которая вывод

Показать ответ
Ответ:
Anna1855
Anna1855
01.03.2023 15:17

Объяснение:

Металлургический комплекс: состав, основные металлургические базы и факторы размещения предприятий. Проблемы и перспективы развития. Металлургия и проблемы охраны окружающей среды.

Количество и качество выплавляемого металла во многом определяет экономическую мощь государства.

Отрасль включает черную (добыча железной руды, выплавка стали, чугуна и ферросплавов) и цветную металлургию (производство легких (алюминий, магний, титан) и тяжелых (медь, никель, олово, свинец) металлов) .

Металлургия сильно загрязняет воздух, воду, и экологический фактор становится главным для ее размещения.

Для производства 1 т стали нужно 7 т руды и кокса, поэтому на размещение отрасли влияют также сырьевой и топливный факторы. Новые производства не требуют кокса, но требуют много электроэнергии, т. е. энергетический фактор тоже важен для отрасли.

Главные базы цветной металлургии — Центральная (вокруг КМА) , Уральская и Сибирская (на юге ЗападнойДля руд тяжелых цветных металлов характерно низкое содержание металла в руде (для выплавки 1 т меди надо 100 т руды, 1 т олова — 300 т) , т. е. главным фактором размещения является сырьевой. Легкие цветные металлы получают методом электролиза. Поэтому их производство очень энергоемко (для производства 1 т алюминия требуется 17 тыс. кВт • ч электроэнергии, а 1 т титана — до 60 тыс. кВт • ч) . Следовательно, главный фактор размещения этого производства — энергетический.

Поэтому производство тяжелых цветных металлов размещается в районах добычи их руд (Урал, Норильск, Кольский полуостров) , а производство легких металлов — у источников дешевой электроэнергии — у крупных ГЭС в Братске, Красноярске.

Важнейшие задачи, которые должны быть решены в отрасли — это освоение новых богатых месторождений меди в Забайкалье, более полное извлечение из руд всех полезных элементов, решение задач охраны природы на предприятиях отрасли.

В современных условиях важно повышение качества металла, увеличение ассортимента проката. Путь решения — создание мини-заводов с современными технологиями, использующих металлолом и не оказывающих сильного отрицательного воздействия на природу.

0,0(0 оценок)
Ответ:
karolka10201020
karolka10201020
13.05.2023 23:36

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

Объяснение:

Program asd;

uses crt;

var a,b,c,max:integer; r:real;

begin

 Write('Введите число A: '); 

Readln(a);

 Write('Введите число B: '); 

Readln(b); 

Write('Введите число C: '); 

Readln(c); 

If  a>=b then max:=a

 else 

 max:=b;   

 If c>max then

max:=c; 

r:=a+b+c;

 If (A>B) and (B>C) and (C>0) then

 Writeln('A= ',a*2,' B= ',b*2,' C= ',c*2);

 If (A<0) and  (B<0) and (C<0) and (A<>B) and (B<>C) and (C<>A)  then

 begin   

A:=max;   

 B:=max; 

 C:=max; 

Writeln('A= ',a,' B= ',b,' C= ',c); 

  end   

else   

 Writeln('Symma: ',r);

end

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота