В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
25tajna
25tajna
23.01.2021 11:31 •  Информатика

На обработку поступает последовательность из четырёх целых чисел. нужно написать программу, которая выводит на экран сумму всех отрицательных чисел последовательности и максимальное число в последовательности. известно, что вводимые числа по абсолютной величине не превышают 1000. программист написал программу неправильно. var s,i,x,mx: integer; begin mx : = 0; s : = 0; for i : = 1 to 4 do begin read (x); if x < 0 then s : = x; if x > mx then mx : = x; end; writeln(s); writeln(mx) end. последовательно выполните следующее. 1. напишите, что выведет эта программа при вводе чисел -5 2 -4 3. 2. пример такой последовательности, содержащей хотя бы одно неотрицательное число, что, несмотря на ошибки, программа печатает правильный ответ. 3. найдите в программе все ошибки (их может быть одна или несколько). для каждой ошибки выпишите строку, в которой она допущена, и эту же строку в исправленном виде.

Показать ответ
Ответ:
vitalik153fb
vitalik153fb
04.10.2020 08:43
1. -4 3
2. 0 0 -4 3
3. Слишком много, хотя бы то, что для i тип integer не нужен, да и if'а можно избежать)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота