В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
win66123
win66123
01.02.2023 07:47 •  Информатика

На паскале написать программу которая в последовательность чисел( натуральных), определяет сумму всех чисел кратных 4 и оканчивающихся на 6. программа получает на вход нат числа, признаком окончания ввода явл число 0. могу решить и сам, только нельзя на компе проверить. так что надеюсь на вас.

Показать ответ
Ответ:
lovenastya87
lovenastya87
07.07.2020 18:20
Var
  a: integer;
  s: longint;

begin
  s := 0;
  a := -32768;
  while a <> 0 do
  begin
    readln(a);
    if a <> 0 then
      if a mod 4 = 0 then
        if a mod 10 = 6 then s := s + a
  end;
  writeln('Сумма равна ', s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота