В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Mashannjjj
Mashannjjj
23.07.2020 05:35 •  Информатика

На паскале написать программу сокращения дроби , где n – целое, m – натуральное число. использовать алгоритм евклида. разработать тесты для проверки правильности работы программы.

Показать ответ
Ответ:
Juliavaishle1
Juliavaishle1
22.09.2020 12:08
Program ex2;
uses crt;
var a, b, x: real;
begin clrsc;
write('a='); readln(a);
write('b='); readln(b);
{алг. Евклина для НОД}
end.
0,0(0 оценок)
Ответ:
26090204A
26090204A
22.09.2020 12:08
Var
 n,m:integer;
 a,b:integer;
begin
 read(n,m);
 a := abs(n);
 b := m;
 while a <> b do
   if a > b then
     a := a - b
   else
     b := b - a;
 b := m div a;
 a := n div a;
 writeln(a,'/',b);
 if a*m = b*n then writeln('Correct')
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота