В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Пупс2014
Пупс2014
27.12.2020 20:25 •  Информатика

На паскале нужно решить 1.задано трехзначное число. составьте программу, с которой определите произведение кубов цифр этого числа. 2.задано трехзначное число. составьте программу, с которой определите , равняются ли в нем крайние числа.

Показать ответ
Ответ:
ioiaaea33
ioiaaea33
04.10.2020 14:47

var
a,e,d,s,p: integer;
begin
p:=1;
writeln ('введи трехзначное число');
read (a);
e:= (a mod 10);
s:=(a div 100);
d:=s*100-e;
 p:=s*s*s*d*d*d*e*e*e;
 writeln ('произведение кубов цифр числа равно',p);
if e=s then writeln ('первая цифра числа равна последней')
  else
writeln ('первая цифра числа не равна последней');
end.


0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота