В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
123456qwe1234567
123456qwe1234567
20.03.2020 07:57 •  Информатика

На паскале составить программу нахождения количества отрицательных элементов в заданном массиве из 10 действительных чисел

Показать ответ
Ответ:
dim10102806
dim10102806
30.06.2020 21:58
Var a, i:integer;
var arrayx = array[0..10] of integer;   
begin 
arrayx[0] = -1;
arrayx[1] = 3;
arrayx[2] = 5;
arrayx[3] = -3;
arrayx[4] = -2;
arrayx[5] = -7;
arrayx[6] = 2;
arrayx[7] = 3;
arrayx[8] = -10;
arrayx[9] = 0;
for i := 1 to 10 do
begin
if (arrayx[i] < 0) a:= a + 1; 
end;
writeln("Отрицательных чисел: ", a);
readln;
end.
0,0(0 оценок)
Ответ:
linalevchuk19
linalevchuk19
30.06.2020 21:58
Program test;
const n = 10;
var i,k:integer;
m: array[1..n] of integer;
begin
for i:=1 to n do
begin
write(' Введите [',i,'] член масива: ');
readln(m[i]);
end;
for i:=1 to n do if m[i]<0 then inc(k);
writeln('Количество чисел меньших нуля :',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота