Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Мне0нужна0помощь
02.05.2021 00:30 •
Информатика
На паскале. вводятся координаты x, y для n точек. определите, сколько точек в круг радиуса r. сколько точек в кольцо с меньшим радиусом r1, большим r2.
Показать ответ
Ответ:
Nastya45t7
24.09.2020 18:59
Var x,y,R,R1,R2,rt:real;i,N,k,m :integer;begin
R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N);
for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);
if rt < R then k:= k + 1;
if (rt < R2) and (rt > R1) then m:= m + 1;
end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.
0,0
(0 оценок)
Популярные вопросы: Информатика
sanyasoloveva1
17.06.2020 06:17
Гиперссылки. Урок 1 Определи правильный порядок установки внутренней гиперссылки в текстовый документ В открывшемся окне в разделе «Связать» выбрать «местом в документе»Вызвать...
пматмг
23.10.2020 23:28
Гиперссылки. Урок 1 Определи последовательность действий необходимых для отмены использования клавиши Ctrl при переходе по гиперссылкевыбрать пункт «Дополнительно»выбрать...
debilNemnogo
01.06.2020 04:21
Какую логическую операцию нужно добавить в программу вместо многоточия, чтобы значение переменной «a» после выполнения фрагмента программы стало равно 3? a : = 10; b : =...
Роли5
01.06.2020 04:21
Определите значение переменной «a» после выполнения фрагмента программы: a : = 10; b : = 5; if not (a 5) then a : = 5;...
Kepka229
17.10.2022 21:05
Найти сумму 8+5 в двоичных кодах и произвести проверку...
orlovapolina14
22.01.2021 00:22
Какая формула будет получена при копировании в ячейку D3,формулы из ячейки D2...
fuccatsumi1
18.05.2023 00:32
ответьте на вопрос: «Что символизируют имена героев: Макар и Варенька? Почему автор дает героям фамилии Девушкин и Доброселова»?...
BkyCHblu5DoLLluPaK
21.11.2022 11:04
В системе координат даны координатные векторы i и j и векторы а, b, c, d, e, f, g, h, k. Определи:У каких векторов координата х=0?Возможно несколько вариантов ответов из:...
Алла1666666
25.07.2021 23:53
Try out different sports Match the photos to the names of the sports.ParaglidingRaftingArcheryCycling...
XxXBulykXxX
09.03.2023 13:36
Основу термодинамики составляют два закона Ложь/Истина ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
R:= 15; R1:= 12; R2:=25;write('Введите N'); Read(N);
for i:=1 to N do beginwrite('Введите координаты х и у'); Read(x,y);rt:=sqrt(sqr(x)+ sqr(y));writeln('r =':3,rt:6);
if rt < R then k:= k + 1;
if (rt < R2) and (rt > R1) then m:= m + 1;
end;writeln; writeln('Количество точек в кругу с радиусом R = ',k);writeln('Количество точек в кольце = ',m);end.