В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Kkb194
Kkb194
10.04.2023 02:59 •  Информатика

На питон Создайте класс Circle, который опишете тремя свойствами: координаты точки центра и радиус. Опишите конструктор класса. Опишите метод, вычисляющий площадь окружности. Напишите программу, в которой введите данные об n окружностях. Выведите информацию о созданных окружностях и их длинах.

Показать ответ
Ответ:
PolinaEpifanova
PolinaEpifanova
23.04.2023 11:07

/*Твой код написан на С++, поэтому я так понимаю, что ответ нужен также на нём.*/

#define _CRT_SECURE_NO_WARNINGS

#include <iostream>

#include <string>

#define SIZE 256

int main() {

   const char* DELIMITERS = "_.,;:\n\t!?";        

   char S[SIZE] = "Hello, my2. friend_ia2m?hh2";    

   char* ptr = 0;  

   ptr = strtok(S, DELIMITERS);

   while (ptr) {                

       for (int i = 0; i < strlen(ptr); i++) {

           if (isdigit(ptr[i]))

               std::cout << ptr << "\n";

       }

       ptr = strtok(0, DELIMITERS);    

   }

   return 0;

}

0,0(0 оценок)
Ответ:
milanademidova1
milanademidova1
31.05.2020 16:52

Растровая графика

1. применяется при разработке электронных полиграфических изданий

2. фотографическое качество, легко могут быть распечатаны на принтере

3. большие размеры, плохо масштабируются

4. Paint, adobe Photoshop (самые популярные)

5. GIF, JPEG, TIFF, PSD

6. применяют в интернете, при разработке электронных (мультимедийных) и полиграфических изданий

Векторная графика

1. это метод создания компьютерного изображения, которое строится посредством обработки математического описания в специальном программном обеспечении.

2. занимают относительно небольшой объем памяти, изображение может легко масштабироваться без потери качества.

3. графика не позволяет получать изображения фотографического качества. Векторные изображения теряют качество при распечатывании

4. shareware, adobe illustrator

5. EMF, SVG, Al и тд.

6. в рекламных агентствах, в редакциях и издательствах и тд.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота