В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vztositgicgc
vztositgicgc
12.07.2022 16:33 •  Информатика

НА ПИТОНЕ 3 ТОЛЬКО АРИФМЕТИЧЕСКИМИ ОПЕРАЦИЯМИ!

Имеется n кг металлического сплава. Из него изготавливают заготовки массой k кг каждая. После этого из каждой заготовки вытачиваются детали массой m кг каждая (из каждой заготовки вытачивают максимально возможное количество деталей). Если от заготовок после этого что-то остается, то этот материал возвращают к началу производственного цикла и сплавляют с тем, что осталось при изготовлении заготовок. Если того сплава, который получился, достаточно для изготовления хотя бы одной заготовки, то из него снова изготавливают заготовки, из них — детали и т.д.

Напишите программу, которая вычислит, какое количество деталей может быть получено по этой технологии из имеющихся исходно n кг сплава.

Программа получает на вход три натуральных числа n, k, m, каждое в отдельной строке, при этом m≤2×10^9,k≤2×10^9,n≤2×10^9.

Выведите одно число — количество деталей, которое может получиться по такой технологии.

Показать ответ
Ответ:
MariHarutyunyan
MariHarutyunyan
28.12.2020 00:02

начнём с того,что s трапеции-это 1/2 a*h (1/2 основания на высоту).

теперь,с этими знаниями,переходим в pascal abc.net.

начинаем с названия программы.

program pltrap; (pltrap-это сокращенно площадь трапеции.если хочешь,можешь написать за место этого то,что хочешь ты).

задаем переменные.

var a,b,c: real; (а-это высота,b-это средняя линия,с-сама площадь трапеции. real-тип переменных чисел.real-значит число может быть как целым,так и не целым).

begin - (начало решения).

возьмем наши переменные,которые будем записывать в строку.

readln(a); - высота.

readln(b); - основание.

c: =0.5*a*b - это наша формула для нахождении площади.1/2-это 0,5.в паскале нужно писать в целых числах вместо запятой точку.

writeln(c); - это то,что нам надо найти,то,что высветится,как ответ,в окне вывода.в нашем случае-это площадь.

end. - конец программы (на конце ставим точку).

итак,что у нас получилось:

program pltrap;

var a,b,c: real;

begin

readln(a);

readln(b);

c: =0.5*a*b;

writeln(c)

end.

теперь пишем в окно ввода числа.

первое число-это a (высота),потому что мы ее задали первой в команде readln(a);

потом-b (основание).

и получаем,чему будет равна площадь.например.пишем числа:

10

2

s=1/2*a*c=0,5*10*2=10- это число выдаст паскаль.

не забывай про ;

если будут вопросы-пиши мне.

0,0(0 оценок)
Ответ:
Albert116
Albert116
10.03.2020 16:03

var j, a, b, n: integer;

label 1;

begin

1: randomize;

  a: = random (9);

  b: = random (9);

  write (a, '*', b, '=');

  read (n);

  if n = (a * b) then writeln ('відповідь вірний! ')

            else writeln ('відповідь неправильний! ');

  writeln ('продовжуватимеш? ');

  writeln ('якщо так то натисни 1');

  writeln ('якщо немає то натисни 2');

  read (j);

  if j = 1 then goto 1;

  if j = 2 then writeln ('до побачення! ');

end.

начебто так, точно не пам'ятаю.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота