В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Flexx1337
Flexx1337
30.05.2022 20:41 •  Информатика

На Питоне ! Напишите программу, которая будет считать суммы положительных и отрицательных чисел отдельно.

Пользователь будет вводить число, а программа будет проверять: если число больше нуля, то программа добавляет его к сумме положительных. Иначе, добавляет к сумме отрицательных.

Всего программа будет проверять 5 чисел, а после этого выводить два числа: сумму всех положительных чисел и сумму всех отрицательных.

Показать ответ
Ответ:
Азрет2002
Азрет2002
26.05.2021 20:20

s1 = 0

s2 = 0

for i in range(5):

   a = int(input())

   if a < 0:

       s1 = s1 + a

   elif a > 0:

       s2 = s2 + a

print(s1, s2)

Не забудь проставить табуляцию, знания любят пробелы съедать.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота